Nissan Altima Forum banner

acceleration

  1. weird noise when accelerating

    Maintenance & Repair
    bought an 06 nissan altima SE 3.5 v6. it has about 149k on the engine. changed the camshaft sensor the day of purchase. now im driving and i notice that when im accelerating at about 1000-2000 rpm at around 20 mph, there is a grinding noise coming from the front. after i increase speed it goes...
  2. 2008 Altima Shudders when accelerating

    New Member Area
    My 2008 Altima just recently started shuddering and vibrating throughout the vehicle when accelerating. On the open highway, when turning the steering wheel to the left it feels like the front wheels are going to come off it vibrates so hard. In the beginning when I let off of the gas pedal, the...
  3. New to it all...Ownership/Nissan/etc!

    New Member Area
    Howdy Folks, 28 year old living here in Dallas, Texas and new owner of a 2008 Nissan Altima 2.5s! I've actually have never owned my own car, believe it or not, but I'm excited to learn as much as I can. I certainly want to trick it out eventually, but it'll be a little a time, but I'm...
  4. won't accelerate past 60mph?

    Maintenance & Repair
    New member here. I have a 2009 Altima SE. This past weekend I was having a minor issue, and I want to get advice on how serious this could be. I have about 50,000 miles on it. I was driving for about 2 hours in 95 degree heat, and I mostly had the cruise set to 70mph. After about 2 hours, I took...
  5. 94 nissan altima gle acceleration problems

    1st Generation Altima (1993-1997)
    Ok, so im bad with car terminology and trying to learn more how to fix a car myself than send it to shops. The problem is that my car accelerates weird. I floor it and the car isnt accelerating at all at times and the engine even dies out and regains strength and starts running at the speed it...
  6. Altima 3.5SE - sudden acceleration issue w/cruise control "coast" function

    3rd Generation Altima (2002-2006)
    2004 Nissan Altima 3.5SE. The car sometimes accelerates - unexpectedly and quite noticeably - for 1 to 3 seconds if in cruise control mode, and I press the "coast" button. Thankfully, pressing the brake and/or removing my finger from the "coast" button provided a temporary fix. That said, the...
  7. Problem with 09 Altima Coupe

    4th Generation Altima (2007-2009)
    For any 06+ Altima Coupe or Sedan owners, would like to know if you have experienced the following issue. Upon initial acceleration when starting the vehicle after it has been shut off/iidle, there is a low 'thump' sound felt in the gas pedal. It only happens one time and can't be repeated...
Top