Nissan Altima Forum banner

problems

  1. Newb with urgent help needed

    New Member Area
    Hey everyone! I'm pleased to be a part of the Altima forums. I've got an '06 L31 Altima 2.5S Sedan, 2.5L/4-speed auto trans, a little over 115K gentle freeway miles. Recently, the AC quit working, but I don't have the time or money to diag/repair it. I was curious if anyone was having the...
  2. Problem with 2013 Altima 2.5 S

    Maintenance & Repair
    While driving home today I heard a very loud pop which to me sounded like it came from right under the transmission hump. The next thing that happened was a loud hissing noise started coming out of the air vents which lasted for about 30 seconds or so and then stopped but reappeared a minute or...
  3. AC not working - Help Please 07 Altima

    4th Generation Altima (2007-2009)
    Hello everyone, I have an 07 Altima here is the problem. The AC is straight blowing hot air (outside air) I took the car to a repair shop and they checked the ac compressor to see if it was working, if it was low on freeon.. everything is good they told me to replace the Ambient Air Temperature...
  4. Transmission replaced, 80k, car still jerks!! WTF!

    4th Generation Altima (2007-2009)
    I noticed car shaking around the first couple of gears in my 08 altima 2.5. Took it to dealer said replaced transmission as it was bad and under warranty. Day after car wouldnt start, towed to dealer said they ran diagnostics and found some misfire codes engines not covered anymore so charged me...
Top