Nissan Altima Forum banner
1 - 1 of 1 Posts

·
Administrator
Joined
·
196 Posts
Since you're getting multiple DTCs which are not related, there may be a problem with the charging system. A properly working charging system puts out about 13.2 to 15.0 volts. A battery should have a static charge of 12.3-12.8 volts when the engine is shut off. If a battery is not good, the charging system may not be able to charge properly. If a vehicle is not charging properly and the battery is good, the first thing to do is to turn the ignition switch to the "ON" position without starting the engine and make sure the charging system warning light is operating. If the bulb is burnt out, the charging system will not charge. If the bulb is OK but still does not illuminate, the circuit must be tested. If the warning lamp does illuminate, then the next thing to check is to make sure the circuit between the battery positive post, or fusible link, to the connection in back of the alternator is good. On Nissans, this will be a thick (approx. 10 gauge) white wire to the "BAT" post on the back of the alternator. It's not uncommon for this wire to get corroded and burn up, creating resistance in the circuit. So, before assuming an alternator is bad, make sure this circuit is good and battery voltage is getting to the alternator. It's also important to make sure the alternator belt is tight and not slipping and the battery connections are clean and tight.

When a charging system is not charging, or overcharging, a lot of "strange" things can occur. It's not uncommon to see a multiple of stored trouble codes in the ECM memory. So, whenever a car is setting a multiple of trouble codes, idling funny or stalling, or anything out of the "norm," test the charging system before you start pulling hairs!

When replacing electrical components such as alternators, starters and distributors, fuel injectors and sensors, always replace with new or reman'd Nissan OEM components; aftermarket components generally don't last long, don't work right and many times are DOA.

Other things that could cause bogging down:
* Incorrect fuel pressure. Tee-in a temporary fuel pressure gauge between the fuel feed hose and the fuel rail. The readings at idle should be as follows:
  • with vacuum hose connected to the fuel pressure regulator: 34 psi
  • with vacuum hose disconnected from the fuel pressure regulator: 43 psi
* There may be a major intake system vacuum leak. To check the intake system for a vacuum leak, attach a vacuum gauge to a full vacuum source. With the engine fully warmed up, the reading at idle should be 18 - 20 InHg. At 3,000 RPM, it should be around 21 InHg. If readings are under 18 InHg, check the intake manifold nuts to make sure they are tight. The gasket may have failed; spray a water mist at the gasket to see if the gauge reading changes. Also check the intake plenum bellows at the throttle valve and at the MAF for cracks or loose clamps.
 
1 - 1 of 1 Posts
Top