Nissan Altima Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
My 2006 2.5 Altima has been had a really long crank time for almost a year now it literally cranks for probably 5 to 10 seconds before starting.. 3 different times the car wouldn't start period it would just crank. Any suggestions? My fuel pump still sounds start but I thought it might be the regulator? Or is it this crank and cam shaft problem I keep hearing about? I have no lights on at all.

Thanks for the help
 

·
Registered
Joined
·
2,832 Posts
My 2006 2.5 Altima has been had a really long crank time for almost a year now it literally cranks for probably 5 to 10 seconds before starting.. 3 different times the car wouldn't start period it would just crank. Any suggestions? My fuel pump still sounds start but I thought it might be the regulator? Or is it this crank and cam shaft problem I keep hearing about? I have no lights on at all.

Thanks for the help


Yes, the cam sensor or more often crank sensor can be the problem. See if this helps you out.

http://www.altimaforums.net/04-crank-position-sensor-t4809.html?t=4809&highlight=Crank+sensor

I also wouldn't overlook something such as plugs.


* odd that your not getting a code, that's why I wouldn't overlook something else.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
Well little update I eliminated the spark plugs and put some NGK's in and still hard long starts... also put in a yellow top battery which didnt help but needed to be replaced anyway. Picked up a crank sensor and I'm putting that in next weekend... I guess if that doesnt do the trip I will do the starter next and my last option is the fuel pump.. the car as 111,xxx on it so I guess it wont hurt to start updating parts anyway.
 

·
Registered
Joined
·
2,832 Posts
Update once you get the crank sensor replaced. Had the plugs been replaced prior?
 

·
Registered
Joined
·
11 Posts
If you check fuel pressure it should be about 50 - 55psi. Once you turn the engine off and the key goes to the off position fuel pressure should hold for a while, it may go down 5 - 10 psi but thats it. If it keeps going down then that means your fuel pressure regulator is bad here at nissan we usually replace the complete fuel pump assembly because we dont replace just the fuel pressure regulator thats inside the unit. This is a very common symptom. If you scan your car for codes and find codes like P0335 crankshaft position sensor then you have a bad crank sensor you need to replace. If you have P0340 code then you have a bad cam sensor that you need to replace. These sensors going bad can cause the extended crank symptom too and may not always throw a light on but will be stored as pass codes in your ecm which can be retrieved with a scanner
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
If you check fuel pressure it should be about 50 - 55psi. Once you turn the engine off and the key goes to the off position fuel pressure should hold for a while, it may go down 5 - 10 psi but thats it. If it keeps going down then that means your fuel pressure regulator is bad here at nissan we usually replace the complete fuel pump assembly because we dont replace just the fuel pressure regulator thats inside the unit. This is a very common symptom. If you scan your car for codes and find codes like P0335 crankshaft position sensor then you have a bad crank sensor you need to replace. If you have P0340 code then you have a bad cam sensor that you need to replace. These sensors going bad can cause the extended crank symptom too and may not always throw a light on but will be stored as pass codes in your ecm which can be retrieved with a scanner
I do believe my pressure regulator might be going bad as well but I do know the sensors have never been replaced on this car so I figured I would start with the cheapest part first haha... the fuel pump looks very easy to replace so ill probably be doing that soon as well. My car hasn't thrown any codes yet but I think the owner before me did some shady stuff to this car because I have a couple wires that our cut under the dash and I have no clue that they are for... couple other little signs so who knows the check engine light could be taken out of busted for all i know.

Thanks for the help guys
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
Update... the car stopped starting today... just sits and cranks. I can no longer hear the whine of the fuel pump is this my issue? or could it possible be a sensor or something else? Like I said just sits and cranks but never fires.
 

·
Registered
Joined
·
3,493 Posts
Fuel pump maybe !
 

·
Registered
Joined
·
22 Posts
Discussion Starter #11
Fuel pump maybe !
Replaced the fuel pump yesterday it starts now but it's still long cranking and starting hard so I don't think it was the fuel pump at all. This car is about to see it's ass going down the road with a new owner in about 2 days unless I figure out whats wrong with it.
 

·
Registered
Joined
·
3,493 Posts
Well , that s a PITA right .
 

·
Registered
Joined
·
3,493 Posts
Do you have some code in there too , you did change the crank sensor , it might , I say might be the cam sensor & also the coil packs too , never know with these electronics nowadays ...

Someone can chimn in with some hints too .

Try search it too .
 

·
Registered
Joined
·
210 Posts
its quite expensive to start replacing parts that you dont even know are bad, you would have saved time and money just bringing it to the dealership or just a local garage. the problem is most likely your cam sensor. dont give up on your car yet.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #16
I tested my fuel pressure and it wasn't holding so it would make sense that the fuel pressure regulator was bad.. I picked up a brand new fuel pump for 201 so it wasn't horrible. Plugs and wires needed to be done as Nissan recommends 105,000 and my car has 111,000. The crank sensor and cam senor are still stock so they are being replaced Friday.

The car has a brand new yellow top battery. I had an electrical test done today as the car as been crapping out on me non-stop and everything came back fine. Strong alt and starter.

The car will always start it's just a guess as to how many times I will have to sit and try to get it to crank all the way over.

If the sensors don't fix it the car is hitting the road it's been nothing but drama since we got it.
 

·
Registered
Joined
·
3,493 Posts
Hope you wont spend too much on it buddy .
 

·
Registered
Joined
·
3,493 Posts
Hey RyanSER , I m about an hour & a half from you buddy .
 

·
Registered
Joined
·
22 Posts
Discussion Starter #20
Both cam and crank sensors were 61 dollars together. All the other parts needed to be done the price you pay for buying a car that wasn't well taken care of by the previous owner.
 
1 - 20 of 32 Posts
Top