Nissan Altima Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi, I've replaced coils, plugs, crank/cam sensors, confirmed voltage to coils and still no spark. Cam shaft turns so that's good, new starter and good battery. Fuel pump pressures the system. Spraying starter fluid will give it a split second "fire" but that's it. So...the ECM is not sending codes out, so I'm guessing that is it. Question is how do I diagnose the ECM and if I do need a new/used one, does it need to be re-programed for my specific model? (Oh, I will disconnect the ECM and clean the connectors with cleaner spray....who knows, maybe that could do it!?!)

Thanks in advance!
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
update...mechanic claims its the head gasket. Claims it is not electrical and that it gets spark. NOT starting due to coolant in cylinder/combustion chamber!?! Engine oil/coolant is not milky, no white smoke prior to no start issue. Claims he did a pressure test. Question: Doesn't he need to be able to start the car to do some of the testing and bring the coolant up to temp?
Do I hand crank the engine with the plugs out to try and clean all fluids out, change oil, start it and change oil again to clean it out before adding gasket sealant and change the oil again in 100 miles to make sure it is holding? Seems a lot cheaper than the alternative.
Will it not start if coolant is in the cylinder? They didn't seem dirty to me. Something doesn't seem right about this diagnosis!!
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
If it's blown through on two cylinders then it's entirely possible for a bad head gasket to cause a no-start, and it's also possible for the gasket to blow through the cooling jacket but not the oil jacket. Since the QR25's are so easy to pull plugs on, there's a super-simple way to check for coolant blowing through to the cylinders. Look down the plug holes with a flashlight with the plugs removed, the piston crowns should be uniformly dull black. If coolant has been leaking in, that crown will be shiny or covered with shiny spots and sections. If they're all normal black then it's very unlikely your problem is a head gasket (at least not one that's blown through to the cooling jacket. Head gaskets can blow through between cylinders without affecting the coolant or oil at all).

As far as cranking, head gasket leaks can temporarily hydrolock the engine if one cylinder is leaking badly and not blown through to a second cylinder. This can also blow the fusible link for the starter and cause a no-crank. However, because the cylinder won't hold compression for long with a blown gasket, hydrolocking from a head gasket is always temporary.
That helps, thank you!
If any cylinder is next to the torn gasket, it will not show/hold proper pressure and affect the start?? Correct?? I'm just trying to get it started so that I can ensure proper testing/diagnosis. I was hoping to clean all the piston crowns, change oil and then fire it up with starter fluid to get it going and then continue cleaning fluids out and then use a gasket sealant.
 
1 - 3 of 3 Posts
Top