Nissan Altima Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello Again, Fellow NAH Drivers. I've had my 2007 NAH for about 2 months now, and am really enjoying it. However, I have a feeling that either my gas gauge and/or the fuel consumption computer is acting up. To explain:

After a long nonstop road trip, the computer told me my range was about 45 miles. Not long after, it ceased displaying range in miles and just showed "----". I understand it does that where there is very little fuel remaining. The gas gauge was also just above "Empty". Naturally, I filled up at the nearest reputable ethanol-free station. Herein lies my confusion.

The pump stopped pumping in gas after 15.9 gallons. I even started pumping again to make sure it didn't stop accidentally. Even then it only pumped in a tiny bit, for a total fill-up of less than 16 gallons. Now, the NAH gas tank has a 20-gallon capacity. It seems really suspicious to me that the gas gauge AND the consumption computer would both be essentially telling me I need to fill-up ASAP, when I still have over 4 gallons in the tank. That's 1/5 of the tank and almost 150 miles left!

Anyone else experienced similar issues, or have any insight to this? Thanks in advance!

More particulars about this fill-up:
Miles traveled: 528
Gas used (according to gas pump): 15.9 gallons
MPG (my own calculation): 33.2
 

·
Registered
Joined
·
2 Posts
Hello Again, Fellow NAH Drivers. I've had my 2007 NAH for about 2 months now, and am really enjoying it. However, I have a feeling that either my gas gauge and/or the fuel consumption computer is acting up. To explain:

After a long nonstop road trip, the computer told me my range was about 45 miles. Not long after, it ceased displaying range in miles and just showed "----". I understand it does that where there is very little fuel remaining. The gas gauge was also just above "Empty". Naturally, I filled up at the nearest reputable ethanol-free station. Herein lies my confusion.

The pump stopped pumping in gas after 15.9 gallons. I even started pumping again to make sure it didn't stop accidentally. Even then it only pumped in a tiny bit, for a total fill-up of less than 16 gallons. Now, the NAH gas tank has a 20-gallon capacity. It seems really suspicious to me that the gas gauge AND the consumption computer would both be essentially telling me I need to fill-up ASAP, when I still have over 4 gallons in the tank. That's 1/5 of the tank and almost 150 miles left!

Anyone else experienced similar issues, or have any insight to this? Thanks in advance!

More particulars about this fill-up:
Miles traveled: 528
Gas used (according to gas pump): 15.9 gallons
MPG (my own calculation): 33.2
I noticed I have about 3-4 gallons of gas left when the computer says empty
 
1 - 3 of 3 Posts
Top