Nissan Altima Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Car will not even try to start after replacing fuel pump. Fuel pump was bad, I replaced it, car started, I allowed to run for about 5 mins, turned it off bc I only had about 3/4 gallon in the tank. Car sat for about 2 hours. I added couple gallons of gas and nothing. Car does not turn over. Battery is charged, I even tried jumping it. I replaced all the relevant fuses accept the main on the battery none were obviously bad, fuel pump still can be heard when I turn key. Any ideas?
 

·
Registered
Joined
·
32 Posts
Have you checked the pressure with a fuel pressure tester? Maybe you got a faulty fuel pump. The check valve in the fuel pump may be defective or need fixed/corrected.
Have you checked the fuel filter?
Have you checked the fuel pressure regulator?
Are you getting spark?
Have you checked your timing and other belts? They may need adjusted or replaced as they compensated for a failing fuel pump.
Have you checked your fuel injectors or fuel rail?
Are you pulling a code?
 

·
Registered
Joined
·
2 Posts
Do you have any dash lights on? Is the security light on (Nissan Immobilizer) .. ?
If the NISSAN Vehicle Immobilizer System is malfunctioning, the light will remain on while the ignition switch is placed in the ON position. The Security Indicator Light illuminates to indicate that the security system is either working properly or to let you know that there is a issue.
 
1 - 4 of 4 Posts
Top