Nissan Altima Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have had my 1995 GXE since 1995. I have had no problems till i moved to this small little town in Florida. Now I have had to replace almost everything. I really don't want to let the car go but I'm running out of options. Having said that here is my problem now.

When I get the car started which takes some time. I will push on the gas pedal and the car would stall.

I have changes the Fuel Filter, Mass Air Flow Sensor, Plugs and Wires, and a few smaller items.

I get that usaully pinging sound from where the timing chain is but it has grown louder.

The car has been driven rough in the early years but now hasn't been driven that way in over 3 years.

Has a little over 145K miles

What should I do? I'm really looking for help.
 

·
Registered
Joined
·
10 Posts
I'd consider the possibility that the timing has finally gone out farther than the engine computer can compensate for. Mechanical wear. If it was originally driven rough, then it probably wasn't serviced well, and that cuts down the lifespan significantly. If you know a good import mechanic (and there ought to be about six million in your area), they'll usually give you a free inspection/estimate/two cents worth.
One things for sure...it won't get better on its own.
 

·
Registered
Joined
·
16 Posts
timing components may be so bad timing jumped

i know this is a late reply but hell its been 3 year since you had it running right.
 
1 - 8 of 8 Posts
Top