Nissan Altima Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello Long story short I had a vacuum leak which caused a p171 code I fixed it and then go a code p0507. I tried 10 times doing the manual relearn process but that didn't work I even tried removing a fuel injector plug to get the idle down from 3000 rpm to 800 rpm but since its a hybrid the car wouldn't start unplugged. I then unbolted the throttle body and cleaned it with some cleaner on a rag. I then took it to a mechanic shop where they hooked it up to the computer. I was told that the relearn process was coming back incomplete that something was interfering but no other codes are there. only when first starting before the car warms up it will idle ok but then it would rev and start to gallop which is hurting my gas millage. I also noticed that the car idles normally when the hybrid batt is completely drained but as soon as it charges to a certain point the engine would start to rev again. I know the car would not take a relearn if the car is idling high but not sure how to get it down. I was thinking of turning off the hybrid batt while I tried to do a relearn but not sure how that would work out. My only other option is take it to nissan to have them do the process but Im afraid that they would do what the other mechanic shop did charge me to use the computer just to say they cant do it. I only found information on reg altima and not hybrid so any help would be greatly appreciated
 

·
Registered
Joined
·
6 Posts
Hello Long story short I had a vacuum leak which caused a p171 code I fixed it and then go a code p0507. I tried 10 times doing the manual relearn process but that didn't work I even tried removing a fuel injector plug to get the idle down from 3000 rpm to 800 rpm but since its a hybrid the car wouldn't start unplugged. I then unbolted the throttle body and cleaned it with some cleaner on a rag. I then took it to a mechanic shop where they hooked it up to the computer. I was told that the relearn process was coming back incomplete that something was interfering but no other codes are there. only when first starting before the car warms up it will idle ok but then it would rev and start to gallop which is hurting my gas millage. I also noticed that the car idles normally when the hybrid batt is completely drained but as soon as it charges to a certain point the engine would start to rev again. I know the car would not take a relearn if the car is idling high but not sure how to get it down. I was thinking of turning off the hybrid batt while I tried to do a relearn but not sure how that would work out. My only other option is take it to nissan to have them do the process but Im afraid that they would do what the other mechanic shop did charge me to use the computer just to say they cant do it. I only found information on reg altima and not hybrid so any help would be greatly appreciated
Hey, I am in the same boat (same hybrid Altima) wanted to clean my throttle body & MAF and now have this idle rev issue you are describing. I was able to get into the relearn part, but unable to complete due to EV mode and not idling. Any resolutions or advice? Dealer only? Thanks.
 

·
Registered
Joined
·
6 Posts
So, I was able to figure out the manual relearn process for hybrid and it resolved my idle jumping after throttle body cleaning.

Attached is a screenshot of steps directly from Nissan EC manual for an 08 hybrid! Someone please sticky this & hopefully this helps someone. Took 3 tries to get the timing right; hybrid part is addressed as well. No need to pay dealer for programming.

Full EC manual can be downloaded here.
 

Attachments

1 - 3 of 3 Posts
Top