Nissan Altima Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Okay yall, I have a big problem. Let me start from the beginning. I have a 2003 nissan altima 3.5 se. I got it about a month ago. Well my cruise control has messed up about 3 times, like on hills it will stop working and I'll have to manually turn it off then press the gas and it will go. Well the very last time it did this, the gas pedal would not work. I had to pull into a local gas station thankfully I was right at it when this happened. So I pull in, the car does NOT die. When I put it in park the motor sounds normal, when i put it in reverse and drive it got real quiet and wouldn't move other than rolling because I have my foot off the brake. Well I turned it off because it wouldn't go, I tried to start it back up to see if it would and it didnt. It didnt even try to start, all it did was click. Well we finally got it home. Charged the battery and it worked fine the next day all day. The day after that I drove to walmart and the car did the same thing there except my gauges started going crazy, inside lights started flashing, and my air bag light was flashing. Well i turned it off and the same thing happened. We took the altinator out and went and got it checked and it passed 3 different tests at 2 different places. We got a new one anyways because the old one was in bad shape and my dad was sure that that was the problem because something was running my battery dead and if the alternator isn't working then your battery is powering everything and too long of that will drain the battery. Well after we put a new one it it was still doing the same thing. And in park it wouldn't rev over 2500 rpm. In drive and reverse it wouldn't even go UNLESS THTHE BATTERY WAS FULLY CHARGED! we have it at a shop right now and they can't figure out the problem either. I need help please lol.
 

·
Registered
Joined
·
10 Posts
Interested as I’ve had that problem my car now drives fine will be watching have a Nissan master tech living next door but never see him met him Friday night haven’t seen him again


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Steering Lock Module

Sounds like my current issure almost exactly, the response you are getting from the car is exact. I have come to the definite conclusion that it is the steering wheel lock module that gets stuck and has happened to so many nissans up until 2009 (my car) and starting 2010 they stopped putting that part in and all previous models they put out a recall for that part. It's an anti theft device located under the steering wheel. just have to take the panel under the steering wheel off. I am far from a mechanic, just a jack of all trades and a DIYer first before paying someone to do something i could have figured out.

Any who, the part is about $500 and can very well still wind up failing in the same way because there has been no changes made to the part. yesterday i ordered a bypass module on ebay for $62 it replaces the steering lock module but doesnt not have that same failing mechanism. I will let you know if it works.

Prior to this i have had the car not start about 4 or 5 times and was able to get it going by guessing the first few times, then once i located the problem i would just smack the steering lock module with a hammer a few times which would pop that mechanism back into the correct location and the car would start. This time not so much luck. I'll post a few links on info and the ebay part.
 
1 - 4 of 4 Posts
Top