Nissan Altima Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Got 2016 altima 2.5 sv, every morning i drive my car i keep hearing some weird noises like (screeching,rattling,whistling and some fainted knocking) the moment i accelerate the engine weird noises will start to hear, good thing it doesn’t affect my driving but it bothers me because it keeps happening, it all started after i brought it to the dealership (where i also bought it) because check-engine light went on and after some diagnosis they had to change the transmission fluid, came back the next day to pick it up after like 3 days since the maintenance weird noises started to appear..
 

·
Registered
Joined
·
130 Posts
If the car is in park and the engine is operating, does the noise occur while it's idling; how about when the engine is revved up? If the noise only occurs when you're driving on the road, then the problem could be somewhere in the drive line such as CV joints, wheel bearings or the CVT itself.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
No, only when I'm driving, specially every morning after a cold start when i shift from reverse to drive the moment i step on the gas pedal it will make a loud screeching sound then while driving there’s this whistling noise i kept hearing, when trying to add some power a rattling noise will start to appear..
 

·
Registered
Joined
·
130 Posts
No, only when I'm driving, specially every morning after a cold start when i shift from reverse to drive the moment i step on the gas pedal it will make a loud screeching sound then while driving there’s this whistling noise i kept hearing, when trying to add some power a rattling noise will start to appear..
Got 2016 altima 2.5 sv, every morning i drive my car i keep hearing some weird noises like (screeching,rattling,whistling and some fainted knocking) the moment i accelerate the engine weird noises will start to hear, good thing it doesn’t affect my driving but it bothers me because it keeps happening, it all started after i brought it to the dealership (where i also bought it) because check-engine light went on and after some diagnosis they had to change the transmission fluid, came back the next day to pick it up after like 3 days since the maintenance weird noises started to appear..
From what you're describing, it sounds like something is wrong in the CVT. The interesting thing you mentioned is the car was OK (except for the DTC) before you took it to the dealership and now you have these loud noises. What was the actual DTC code that gave the check-engine light? When the dealership replaced the CVT fluid, maybe they put in the wrong fluid. The CVT fluid for your CVT needs to be: NS-3.
 

·
Registered
Joined
·
514 Posts
When the dealership replaced the CVT fluid, maybe they put in the wrong fluid. The CVT fluid for your CVT needs to be: NS-3.
Could be overfilled, too. Wouldn't be the first time, unfortunately a lot of dealerships (of all brands) let oil changers do CVT D&F's. I'd jack it up flat and yank the leveling plug to see what comes out.
 

·
Registered
Joined
·
514 Posts
P17F0 is the CVT "death code", it means severe belt slippage was detected and there's almost certain damage to the belt. If the P0841 is current and didn't remain clear after the fluid change, then the valve body has issues too. The short story is, that tranny is dying.
 
1 - 7 of 7 Posts
Top